The incident has now been resolved. Pixel data accuracy is restored, and we are seeing consistent performance across the board.
We deeply appreciate your patience throughout the recovery process. If you continue to experience any unexpected behavior, please don’t hesitate to reach out via live chat or to your dedicated Account Manager— our team is here to help.
In the coming days, we’ll also share a detailed postmortem outlining what led to this incident and the steps we’ve taken to resolve it. And most importantly, the long-term improvements we're implementing to ensure this doesn't happen again.
Posted Jul 22, 2025 - 06:54 UTC
Update
The incident has now been resolved. Pixel data accuracy is restored, and we are seeing consistent performance across the board.
We deeply appreciate your patience throughout the recovery process. If you continue to experience any unexpected behavior, please don’t hesitate to reach out via live chat or to your dedicated Account Manager— our team is here to help.
In the coming days, we’ll also share a detailed postmortem outlining what led to this incident and the steps we’ve taken to resolve it. And most importantly, the long-term improvements we're implementing to ensure this doesn't happen again.
Posted Jul 22, 2025 - 06:54 UTC
Update
Incident is resolved for the vast majority of accounts. We're closely following the remaining accounts to ensure full and consistent data restoration. Thank you again for your patience as we bring this to full resolution!
If you notice anything odd, please reach out to us in the live chat.
Posted Jul 17, 2025 - 19:16 UTC
Update
A fix has been implemented and we are continuing to monitor the results.
At this stage, Pixel data discrepancies remain for a small number of customers, but these are significantly reduced. We’re actively working on a full resolution.
✅ All Shopify data is now accurate. ✅ Most accounts are seeing fully accurate Pixel data.
We’re continuing to explore options to restore complete accuracy for the remaining affected accounts and are optimistic that we’re close to closing this out. Thanks so much for your continued patience!
Posted Jul 14, 2025 - 02:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Please note that while data is still being refreshed, discrepancies in inventory and Pixel data are expected.
Posted Jul 11, 2025 - 14:43 UTC
Investigating
We’re currently investigating an issue affecting our Pixel data pipeline, which may be causing missing, delayed, or inaccurate order data over the past few days.
Our engineering team is actively working to identify the root cause and implement a fix as quickly as possible. We are prioritizing this to ensure data integrity is restored.
No action is required on your end, we’ll continue to share updates here as soon as we have them. Thank you for your patience.