The data delay is now solved, all data should have recovered during the day, not data loss. We had one of our servers go down, and had to restore it manually. We are working on a system to spin up a new instance in case this happens to prevent this from happening in the future. If you want more details about the incident and what we are doing to prevent this from happening in the future, you can reach out to charbel@polaranalytics.co, thanks for your patience, we hope the delay was not too disruptive.
Posted Sep 06, 2026 - 18:55 UTC
Update
A fix has been applied and the data should now be refreshing
Posted Sep 06, 2026 - 06:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 06, 2026 - 06:17 UTC
Investigating
We are currently investigating an issue with Polar Pixel and Amazon Selling Partners data being delayed in the last 2 days.
Posted Sep 06, 2026 - 05:22 UTC
This incident affected: Polar Pixel and Data Pipeline.