Shopify Data Pipeline

Incident Report for Polar Analytics

Resolved

We’ve addressed the root cause of the issue affecting data refreshes for Shopify and Pixel. While data is actively being refreshed, users may still experience some temporary holes in historical data reporting for both Shopify and Polar Pixel. If you see any issues with recent data please inform us directly in the support chat as they are not expected. We're continuing to monitor the pipeline closely to ensure full stability. Thank you for your continued patience!
Posted Jul 09, 2025 - 08:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted Jul 09, 2025 - 04:13 UTC

Update

App is back.

We are continuing to work on the fix.

No action is needed on your end, we’ll keep you updated as we make progress.
Posted Jul 08, 2025 - 17:09 UTC

Update

We performed an upgrade on our database system to support additional load, app went into maintenance mode. We should be back shortly.
Posted Jul 08, 2025 - 16:50 UTC

Identified

Our team has identified the root cause and is implementing an additional fix to fully resolve the issue which was introduced by a recent change in the Shopify API and higher customer load. We’ve started reprocessing data from July 1st to restore it to a consistent and accurate state.

We're doing everything we can to recover the impacted data asap and will notify you as soon as the process is 100% complete.

Once resolved, we’ll also share the preventative measures we’re putting in place to ensure this doesn’t happen again in the future.
Posted Jul 08, 2025 - 16:07 UTC

Investigating

We’re currently investigating an issue affecting our Shopify data pipeline. This may result in inaccurate order data as well as missing or delayed data for the past few days.

Our team is actively working to identify the root cause and will deploy a fix as soon as possible.

No action is needed on your end, we’ll keep you updated as we make progress.
Posted Jul 07, 2025 - 14:00 UTC
This incident affected: Data Pipeline.